incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: CAn't bootstrap a new node to my cluster
Date Tue, 13 Mar 2012 08:36:18 GMT
Can you provide some context for the log files please. 

The original error had to do with bootstrapping a new node into a cluster. The log looks like
a node is starting with -Dcassadra.join-ring = false and then nodetool join is run. 

Is there an error when this runs ? 

Cheers

-----------------
Aaron Morton
Freelance Developer
@aaronmorton
http://www.thelastpickle.com

On 12/03/2012, at 11:58 PM, Cyril Scetbon wrote:

> I don't know if it can helps, but the only thing I see on cluster's nodes is :
> 
> ==> /var/log/cassandra/output.log <==
>  INFO 10:57:28,530 InetAddress /10.0.1.70 is now dead.
> 
> 
> when I try to join the node 10.0.1.70 to the cluster
> 
> On 3/12/12 11:27 AM, Cyril Scetbon wrote:
>> 
>> It's done.
>> 
>> Nothing new on stderr when I use the join command. I send you the logfiles after
I've tried to add the node.
>> 
>> Regards
>> 
>> On 3/12/12 10:47 AM, aaron morton wrote:
>>> 
>>> Modify this line the log4j-server.properties. It will normally be located in
/etc/cassandra 
>>> 
>>> https://github.com/apache/cassandra/blob/trunk/conf/log4j-server.properties#L21
>>> 
>>> Change INFO to DEBUG 
>>> 
>>> Cheers
>>> 
>>> -----------------
>>> Aaron Morton
>>> Freelance Developer
>>> @aaronmorton
>>> http://www.thelastpickle.com
>>> 
>>> On 12/03/2012, at 10:12 PM, Cyril Scetbon wrote:
>>> 
>>>> On 3/12/12 9:50 AM, aaron morton wrote:
>>>>> 
>>>>> It may be the case that the joining node does not have enough information.
But there is a default 30 second delay while the node waits for the ring information to stabilise.

>>>>> 
>>>>> What version are you using ? 
>>>> 1.0.7
>>>>> 
>>>>> Next time you add a new node can you try it with logging set the DEBUG.
If you get the error please add it to https://issues.apache.org/jira/browse/CASSANDRA with
the relevant logs. 
>>>> where do I have to add it ? I added it to the cassandra-env.sh and got a
lot of things but are you saying that I must add it to the join command ? if yes, how ?
>>>> 
>>>> after the join command fails as you saw I have the ring information after
that. I don't if it took 30 seconds or not ...
>>>>> 
>>>>> Cheers
>>>>> 
>>>>> -----------------
>>>>> Aaron Morton
>>>>> Freelance Developer
>>>>> @aaronmorton
>>>>> http://www.thelastpickle.com
>>>> 
>>>> 
>>>> -- 
>>>> Cyril SCETBON
>>> 
>> 
>> 
>> -- 
>> Cyril SCETBON
> 
> 
> -- 
> Cyril SCETBON


Mime
View raw message