0.6.12, we had serious problem with 0.7.x and 0.8.x