This is quite a different subject and the question has already been asked a few days ago (December, 1) : http://www.mail-archive.com/user@cassandra.apache.org/msg19083.html

Anyways, you can test it by yourself changing the name of the column family. I don't know more about it by myself.

Alain

2011/12/11 Michael Vaknine <michaelv@citypath.com>

Hi,

I have a keyspace called Index.

 

I am trying to create it when I create a new cluster from the script that was created on the old cluster.

 

create keyspace Index

with placement_strategy = 'SimpleStrategy'

and strategy_options = {replication_factor : 3

and durable_writes = true;

 

I get an error

 

[default@City] create keyspace Index

...       with placement_strategy = 'SimpleStrategy'

...       and strategy_options = {replication_factor : 3}

...       and durable_writes = true;

Syntax error at position 16: mismatched input 'Index' expecting set null

 

My question is

Is Index a reserved word?

How can I create this keyspace? I tried 'Index' and "Index" but I still get the error and I am not able to create it.

 

Thanks

Michael

 

From: Alain RODRIGUEZ [mailto:arodrime@gmail.com]
Sent: Thursday, December 08, 2011 11:52 AM
To: user@cassandra.apache.org
Subject: Re: Schematool

 

You should be able to use the CLI "show schema yourkeyspace" if your cassandra is recent enough ( >= 0.8 if I remember well. I think it is better if you are in 0.8.7 because this command was fixed a couple of times in 8.6 and 8.7).

 

You can put the "show schema" command into a file and call it with : "cassandra-cli -h yourhost -f yourfile > 20111208schema" then open your output file and remove the 2 or 3 useless lines that are written before "create yourkeyspace".

 

Hope this will be helpful.

 

Alain

 

2011/12/8 Michael Vaknine <michaelv@citypath.com>

Hi,

Since schematool has been removed from Cassandra is there a way to extract
the schema from a working cluster in order to create a new empty cluster?

Thanks
Michael