incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Evans <eev...@acunu.com>
Subject Re: CQL Install for 0.8.X?
Date Tue, 06 Dec 2011 03:38:14 GMT
On Mon, Dec 5, 2011 at 1:40 PM, Joe Stein <cryptcom@gmail.com> wrote:
> Hey, trying to grab cqlsh for a 0.8.6 cluster but all the online docs I am
> finding are pointing to http://www.apache.org/dist/cassandra/drivers/py or
> say it moved to the source and checked there in the 0.8 branch and nothing
> either...

Right, the drivers were moved and the site wasn't updated (until just
now).  The Python driver is now hosted on Apache Extras, here:

http://code.google.com/a/apache-extras.org/hosting/search?q=label:cql

But, that driver probably won't work right with 0.8.6, and the shell
has been moved out of the driver and into Cassandra trunk anyway.
What you probably want is 1.0.3 from here:

http://archive.apache.org/dist/cassandra/drivers/py

Sorry, I know, it's a confusing mess.

> also saw something about about 2.0 not being compatible with 0.8.X
> so not sure where to go from here.

The language incompatibilities are pretty minor, but there were some
changes to the results format that will prevent a new driver (for 1.x)
from working on an older Cassandra (0.8.x).

> Let me know, want/need to jump into a bunch of CQL stuff and want to-do it
> on the cqlsh first if I can.

-- 
Eric Evans
Acunu | http://www.acunu.com | @acunu

Mime
View raw message