If your version of Cassandra does not support composite you need to upgrade, If the server is not aware the column is composite it will not be able to use them to full effect. You likely will not get the sorting and slicing capabilities you want.

Edward

On Sat, Nov 5, 2011 at 4:44 AM, Guy Incognito <dnd1066@gmail.com> wrote:
Is this a lib I can just drop into a 0.7 instance of cassandra and use?  I'm not sure what to make of the README about not using it with versions earlier than 0.8.0-rc1.

https://github.com/riptano/hector-composite

the goal is to start using CompositeTypes in 0.7 (which I can't upgrade to 0.8 at the moment), with a seamless transition to 0.8 when I do upgrade.  will using this with hector 0.8.x allow this?