incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Vaknine" <micha...@citypath.com>
Subject RE: Upgrade Cassandra Cluster to 1.0.2
Date Sun, 13 Nov 2011 15:37:28 GMT
You are right this solved the problem.
I do not understand why version 1.0.0 was not affected since I used the same
configuration yaml file.

Thank you.
Michael Vaknine


-----Original Message-----
From: Brandon Williams [mailto:driftx@gmail.com] 
Sent: Sunday, November 13, 2011 4:48 PM
To: user@cassandra.apache.org
Cc: cassandra-user@incubator.apache.org
Subject: Re: Upgrade Cassandra Cluster to 1.0.2

On Sun, Nov 13, 2011 at 4:35 AM, Michael Vaknine <michaelv@citypath.com>
wrote:
> I am trying to upgrade to 1.0.2 and when I try to start the first upgraded
> server I get the following error
>
>
>
> ERROR [WRITE-/10.5.6.102] 2011-11-13 10:20:37,447
> AbstractCassandraDaemon.java (line 133) Fatal exception in thread
> Thread[WRITE-/10.5.6.102,5,main]
>
> java.lang.NullPointerException
>
>         at
>
org.apache.cassandra.net.OutboundTcpConnectionPool.isEncryptedChannel(Outbou
ndTcpConnectionPool.java:93)
>
>         at
>
org.apache.cassandra.net.OutboundTcpConnectionPool.newSocket(OutboundTcpConn
ectionPool.java:77)
>
>         at
>
org.apache.cassandra.net.OutboundTcpConnection.connect(OutboundTcpConnection
.java:209)
>
>         at
>
org.apache.cassandra.net.OutboundTcpConnection.run(OutboundTcpConnection.jav
a:93)

You are probably missing the encryption options in your yaml.  I
noticed this problem as part of
https://issues.apache.org/jira/browse/CASSANDRA-3045.

-Brandon


Mime
View raw message