incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yan Chunlu <springri...@gmail.com>
Subject Re: progress of sstableloader keeps 0?
Date Fri, 23 Sep 2011 05:23:16 GMT
sorry I did not look into it....  after check it I found version mismatch
exception is in the log:
ERROR [Thread-17] 2011-09-22 08:24:24,248 AbstractCassandraDaemon.java (line
139) Fatal exception in thread Thread[Thread-17,5,main]
java.lang.RuntimeException: Cannot recover SSTable
/disk2/cassandra/data/reddit/Comments-tmp-f-1 due to version mismatch.
(current version is g).
        at
org.apache.cassandra.io.sstable.SSTableWriter.createBuilder(SSTableWriter.java:240)
        at
org.apache.cassandra.db.compaction.CompactionManager.submitSSTableBuild(CompactionManager.java:1097)
        at
org.apache.cassandra.streaming.StreamInSession.finished(StreamInSession.java:110)
        at
org.apache.cassandra.streaming.IncomingStreamReader.readFile(IncomingStreamReader.java:104)
        at
org.apache.cassandra.streaming.IncomingStreamReader.read(IncomingStreamReader.java:61)
        at
org.apache.cassandra.net.IncomingTcpConnection.stream(IncomingTcpConnection.java:189)
        at
org.apache.cassandra.net.IncomingTcpConnection.run(IncomingTcpConnection.java:117)


does that mean I need to run scrub before running the loader?  could I just
delete it and keep going?  thanks!

On Fri, Sep 23, 2011 at 2:16 AM, Jonathan Ellis <jbellis@gmail.com> wrote:

> Did you check for errors in logs on both loader + target?
>
> On Thu, Sep 22, 2011 at 10:52 AM, Yan Chunlu <springrider@gmail.com>
> wrote:
> > I took a snapshot of one of my node in a cluster 0.7.4(N=RF=3).   use
> > sstableloader to load the snapshot data to another 1 node
> cluster(N=RF=1).
> >
> > after execute  "bin/sstableloader  /disk2/mykeyspace/"
> >
> > it says"Starting client (and waiting 30 seconds for gossip) ..."
> > "Streaming revelant part of  cf1.db..... to [10.23.2.4]"
> > then showing the progress indicator and stopped. nothing changed after
> > then.
> > progress: [/10.28.53.16 1/72 (0)] [total: 0 - 0MB/s (avg: 0MB/s)]]]
> >
> > I use nodetool to check the node 10.23.2.4, nothing changed. no data
> copied
> > to it. and the data dir also keep its original size. is there anything
> > wrong? how can I tell what was going on there?
> > thanks!
>
>
>
> --
> Jonathan Ellis
> Project Chair, Apache Cassandra
> co-founder of DataStax, the source for professional Cassandra support
> http://www.datastax.com
>

Mime
View raw message