incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Pope <>
Subject RE: Column Family names
Date Thu, 25 Aug 2011 15:30:50 GMT
Never mind. I've got a hard-coded Count on the KeyRange set to 2 billion, which is apparently
beyond the maximum allowable.

From: Stephen Pope []
Sent: Thursday, August 25, 2011 11:15 AM
Subject: RE: Column Family names

Hmm...I've tried changing my column family name to "MySchema" instead. Now the cli is behaving
normally, but the OOM error still occurs when I get_range_slices from my code.

From: Stephen Pope []
Sent: Thursday, August 25, 2011 11:10 AM
Subject: Column Family names

Using 0.8.2, I've created a column family called "_Schema" (without the quotes). For some
reason, I can't seem to list the rows in it from the cli:

I've tried:

[default@BIM] list _Schema;
Syntax error at position 5: unexpected "_" for `list _Schema;`.
[default@BIM] list '_Schema';
Syntax error at position 5: mismatched input ''_Schema'' expecting Identifier
[default@BIM] list "_Schema";
Syntax error at position 5: unexpected """ for `list "_Schema";`.

Am I doing something wrong?

Also, after creating the (empty) column family, I then try to read the entire column family
using get_range_slices. I'm using an empty byte array for the start key (and start column),
and a byte array containing '\uffff' for the end key (and end column). When I do this, Cassandra
throws this:

java.lang.OutOfMemoryError: Java heap space
Dumping heap to java_pid2508.hprof ...
Heap dump file created [5211347 bytes in 0.100 secs]
ERROR 10:44:07,543 Internal error processing get_range_slices
java.lang.OutOfMemoryError: Java heap space
        at java.util.ArrayList.<init>(
        at org.apache.cassandra.service.StorageProxy.getRangeSlice(StorageProxy.
        at org.apache.cassandra.thrift.CassandraServer.get_range_slices(Cassandr
        at org.apache.cassandra.thrift.Cassandra$Processor$get_range_slices.proc
        at org.apache.cassandra.thrift.Cassandra$Processor.process(Cassandra.jav
        at org.apache.cassandra.thrift.CustomTThreadPoolServer$
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExec
        at java.util.concurrent.ThreadPoolExecutor$

Even though I've got 8GB of ram in my machine, and the java process is only using 92MB of

Has anyone seen this before?


View raw message