incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremiah Jordan <jeremiah.jor...@morningstar.com>
Subject Re: Cassandra 0.6.8 snapshot problem?
Date Tue, 02 Aug 2011 21:08:26 GMT
Does snapshot in 0.6 cause a flush to happen first? If not there could
be data in the database that won't be in the snapshot.  Though that
seems like a long time for data to be sitting in the commit log and not
make it to the sstables.

On Thu, 2011-07-28 at 17:30 -0500, Jonathan Ellis wrote:
> Doesn't ring a bell.  But I'd say if you upgrade and it's still a
> problem, then (a) you're not _worse_ off than you are now, and (b)
> it's a lot more likely to get fixed in modern version.
> 
> On Thu, Jul 28, 2011 at 9:47 AM, Jian Fang
> <jian.fang.subscribe@gmail.com> wrote:
> > Hi,
> >
> > We have an old production Cassandra 0.6.8 instance without replica, i.e.,
> > the replication factor is 1. Recently, we noticed that
> > the snapshot data we took from this instance are inconsistent with the
> > running instance data. For example, we took snapshot
> > in early July 2011. From the running instance, we got a record that was
> > created in March 2011, but on the snapshot copy, the
> > record with the same key was different and was created in January 2011.
> > Yesterday, we created another snapshot and reproduced
> > the problem. I just like to know if this is a known issue for Cassandra 0.6.
> >
> > We are going to migrate to Cassandra 0.8, but we need to make sure this will
> > not be a problem in 0.8.
> >
> > Thanks in advance,
> >
> > John
> >
> >
> 
> 
> 


Mime
View raw message