incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: node stuck "leaving"
Date Sat, 09 Jul 2011 23:47:01 GMT
Check the log on all the machines for ERROR messages. An error on any of the nodes could have
caused the streaming to hang. nodetool netstats will let you know if there is a failed stream.


AFAIK if you restart the cass service on 1 it will forget it was leaving and rejoin in a normal
state.

cheers

-----------------
Aaron Morton
Freelance Cassandra Developer
@aaronmorton
http://www.thelastpickle.com

On 8 Jul 2011, at 16:27, Casey Deccio wrote:

> I've got a node that is stuck "Leaving" the ring.  Running "nodetool decommission" never
terminates.  It's been in this state for about a week, and the load has not decreased:
> 
> $ nodetool -h localhost ring
> Address         DC          Rack        Status State   Load            Owns    Token
                                      
>                                                                                Token(bytes[de4075d0a474c4a773efa2891c020529])
> x.x.x.1   datacenter1 rack1       Up     Leaving 150.63 GB       33.33%  Token(bytes[10956f12b46304bf70412ad0eac14344])
> x.x.x.2   datacenter1 rack1       Up     Normal  79.21 GB        33.33%  Token(bytes[50af14df71eafac7bac60fbc836c6722])
> x.x.x.3   datacenter1 rack1       Up     Normal  60.74 GB        33.33%  Token(bytes[de4075d0a474c4a773efa2891c020529])
> 
> Any ideas?
> 
> Regards,
> Casey


Mime
View raw message