Hi Anuya,

> However, columns are not being inserted.

Do you mean to say that after insert operation you couldn't retrieve the same data? If so, then please check the time-stamp when you reinserted after delete operation. Your second insertion time-stamp has to be greater than the previous insertion.

Thank you,

From: anuya joshi <anucjs@gmail.com>
To: user@cassandra.apache.org
Sent: Monday, 2 May 2011 11:34 PM
Subject: Re: Unable to add columns to empty row in Column family: Cassandra


I am using Cassandra for my application.My Cassandra client uses Thrift APIs directly. The problem I am facing currently is as follows:

1) I added a row and columns in it dynamically via Thrift API Client
2) Next, I used command line client to delete row which actually deleted all the columns in it, leaving empty row with original row id.
3) Now, I am trying to add columns dynamically using client program into this empty row with same row key
    However, columns are not being inserted.
    But, when tried from command line client, it worked correctly.

Any pointer on this would be of great use

Thanks in  advance,