incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Julien <pjul...@gmail.com>
Subject Re: CLI does not list data after upgrading to 0.7.4
Date Mon, 11 Apr 2011 02:13:10 GMT
put in an assumption first, so from cassandra-cli, do:

assume aCF KEYS as lexicaluuid;

then do your list

On Sun, Apr 10, 2011 at 10:03 PM, Wenjun Che <wenjun@openf.in> wrote:
>
> It is happening on clean 0.7.4 server as well.  Here is how to reproduce:
>
> 1. create a CF with UUID as row key
> 2. add some data
> 3. list CF always returns "Input length = 1"
>
> I figured out one way to fix this: run 'assume CF keys as lexicaluuid;".
>
> This issue does not happen to CLI of 0.7.0 or earlier, even running against
> 0.7.4 server.
>
>
>
> On Sat, Apr 9, 2011 at 5:53 PM, aaron morton <aaron@thelastpickle.com>
> wrote:
>>
>> Just tested the 0.7.4 cli against an clean 0.7.4 server and list worked.
>>
>> If I restart the server while the cli is connected i get...
>>
>> [default@dev] list data;
>> Using default limit of 100
>> null
>>
>> Aaron
>>
>> On 8 Apr 2011, at 17:23, Wenjun Che wrote:
>>
>> > Hello
>> >
>> > I just upgraded a 1-node setup from rc2 to 0.7.4 and ran scrub without
>> > any error.  Now 'list CF' in CLI does not return any data as followings:
>> >
>> > list User;
>> > Using default limit of 100
>> > Input length = 1
>> >
>> > I don't see any errors or exceptions in the log.
>> >
>> > If I run CLi from 0.7.0 against 0.7.4 server, I am getting data.
>> >
>> >
>> >
>> > Thanks
>> >
>>
>
>

Mime
View raw message