incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Colby <jonathan.co...@gmail.com>
Subject Re: help! seed node needs to be replaced
Date Mon, 11 Apr 2011 21:43:56 GMT
Yes.  This node has repeatedly given problems while reading various sstables.  So I decided
to start with a fresh data dir, relying on the fact that with an RF=3, the data will be able
to be retrieved from the cluster.

Since this is a seed node, I am a little unsure how to proceed.  From everything I've read,
bootstrapping a seed is not a good idea.  One idea I had was to change the IP, bootstrap,
and change the IP back.    But I just tried nodetool move 0 to try, with the hopes that it
might work.


On Apr 11, 2011, at 11:31 PM, aaron morton wrote:

> Is this the node that had the earlier EOF error during bootstrap ? 
> 
> Aaron
> 
> On 12 Apr 2011, at 08:42, Jonathan Colby wrote:
> 
>> I shutdown cassandra, deleted (with a backup) the contents of the data directory
and did a "nodetool move 0".    It seems to be populating the node with its range of data.
   Hope that was a good idea.
>> 
>> On Apr 11, 2011, at 10:38 PM, Jonathan Colby wrote:
>> 
>>> 
>>> My seed node (1 of 4)  having the wraparound range (token 0) needs to be replaced.
>>> 
>>> 
>>> Should I bootstrap the node with a new IP, then add it back as a seed?   
>>> 
>>> Should I run remove token on another node to take over the range?
>> 
> 


Mime
View raw message