incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: Cluster Installation Verification
Date Tue, 26 Apr 2011 21:14:47 GMT
Does not look like there is much data in there :)

Also don't forget to use the datatype functions in the cli to match what your app is doing,
see help for more details. 
e.g. get MyCf[uuid('something-that-looks-llike-a-uuid')]

Also the ring is unbalanced (the Owns column), you will want to assign the nodes an initial
token so they each take the same portion of the data.
see http://wiki.apache.org/cassandra/Operations#Load_balancing 

Hope that helps. 
Aaron

On 27 Apr 2011, at 07:14, Brad Willard wrote:

> The setup is 10.11.6.9 as the seed and the other three nodes
> bootstrapped. I attached two cassandra.yaml files, the config of the
> seed, and the config of one of the cluster nodes.
> 
> Ring output
> /opt/cassandra/apache-cassandra-0.7.4# ./bin/nodetool -h 10.11.6.9 ring
> Address         Status State   Load            Owns    Token
> 
> 133836233891526335447940652806240328892
> 10.11.6.9       Up     Normal  42.53 KB        50.00%
> 48765642161291719582097000948298276028
> 10.11.6.26      Up     Normal  42.71 KB        12.50%
> 70033290093850373548557913912783789244
> 10.11.6.11      Up     Normal  42.67 KB        12.50%
> 91300938026409027515018826877269302460
> 10.11.6.10      Up     Normal  42.64 KB        25.00%
> 133836233891526335447940652806240328892
> 
> Replicate Strategy is whatever is default, I'm not sure how to set it.
> The consistency leve in the client is set to one.
> 
> Thanks,
> Brad
> 
> On Tue, Apr 26, 2011 at 2:25 PM, Jonathan Colby
> <jonathan.colby@gmail.com> wrote:
>> What replication strategy did you use?  how does the ring look?  were the newly added
nodes bootstrapped? is 1 or more nodes listed as a seed?
>> 
>> Lots of questions.  but maybe you could post your cassandra.yaml here and we can
take a look at it.
>> 
>> The output of nodetool ring would also be good.
>> 
>> Jon
>> 
>> On Apr 26, 2011, at 7:27 PM, Brad Willard wrote:
>> 
>>> I'm trying to setup a cassandra cluster with 0.7.4 on 4 nodes. I
>>> initially did a single server test that went beautifully with a test
>>> that inserted 16 million rows with no issues. However when I tried to
>>> create a 4 node cluster I've been seeing weird behavior. I seem to be
>>> able to run my same test without errors, however when I use the
>>> cassanda-cli to look at the data, it appears as though nothing has
>>> been inserted. I verified the server I've connected to, verified the
>>> correct keyspace and column family. I've already used the nodetool to
>>> verify all the other servers are listed in the ring.
>>> 
>>> I followed these instructions for the setup:
>>> http://wiki.apache.org/cassandra/MultinodeCluster
>>> 
>>> So how can I verify my cluster is working correctly?  Any help would
>>> be amazing as I'm evaluating this for my company.
>>> 
>>> Thanks,
>>> Brad
>> 
>> 
> <cassandra.nonseed.yaml><cassandra.seed.yaml>


Mime
View raw message