incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Choi <paulc...@plaxo.com>
Subject RE: build.xml issue with 0.7.3?
Date Wed, 09 Mar 2011 19:11:15 GMT
Ah, the plot thickens...

I downloaded Ant 1.8.2, tried building Cassandra 0.7.3. That works fine.

CentOS 5 comes with ant 1.6.5, and that does not work with Cassandra 0.7.3

I see in Cassandra's changelog that, in 0.7.1, ivy was replaced with maven-ant-tasks. Now,
maven-ant-tasks requires ant 1.6x and newer, so you'd think it works.

I'll need to build a newer Ant RPM for my build system, then try building Cassandra 0.73.

Thanks for your help!


________________________________________
From: Paul Choi [paulchoi@plaxo.com]
Sent: Wednesday, March 09, 2011 10:52 AM
To: user@cassandra.apache.org
Subject: RE: build.xml issue with 0.7.3?

Eric,
Thanks for your response.

This is all I see in /build:
[paulchoi@build02 build]$ find .
.
./lib
./maven-ant-tasks-2.1.1.jar
[paulchoi@build02 build]$

I just downloaded a new copy of 0.7.3-src and tried manually. I'm still running into the same
problem.

I tried doing this with 0.7.0, and ant downloads Ivy and Ivy takes care of the dependencies.
With 0.7.3, maybe Ant doesn't get to the point of downloading Ivy? I guess I need to wise
up on Ant and Ivy myself.

-Paul

________________________________________
From: Eric Evans [eevans@rackspace.com]
Sent: Friday, March 04, 2011 7:36 PM
To: user@cassandra.apache.org
Subject: Re: build.xml issue with 0.7.3?

On Sat, 2011-03-05 at 01:23 +0000, Paul Choi wrote:
> We're running 0.7.0, and we want to upgrade to 0.7.3 ASAP.
>
> This worked in our RPM SPEC file with 0.7.0:
> %build
> export JAVA_HOME=/usr/java/latest
> ant clean jar -Drelease=true
>
> Now running "ant jar" throws some kind of build.xml error at line 155 - typedef is undefined.
I'm running ant 1.6.5-2jpp.2 that comes with CentOS 5.5. Unfortunately, I'm no Ant expert,
so I'm stumped. Does anyone have any idea why this is happening?

0.7.0 pulled down dependencies using Ivy, 0.7.3 uses maven-ant-tasks.
This error occurred when trying to create the artifact typedef for
maven-ant-tasks, though I don't know why (it works here).

What do the contents of build/ look like after the error?

> Thanks for your help.
> BTW, I grabbed the tarball from http://apache.org/dist/cassandra/0.7.3/, since the mirrors
didn't have it. I hope it was ok to get this one.
>
> [paulchoi@build02 apache-cassandra-0.7.3-src]$ ant jar
> Buildfile: build.xml
>
> maven-ant-tasks-download:
>      [echo] Downloading Maven ANT Tasks...
>     [mkdir] Created dir: /home/paulchoi/rpm/SOURCES/apache-cassandra-0.7.3-src/build
>       [get] Getting: http://repo2.maven.org/maven2/org/apache/maven/maven-ant-tasks/2.1.1/maven-ant-tasks-2.1.1.jar
>       [get] To: /home/paulchoi/rpm/SOURCES/apache-cassandra-0.7.3-src/build/maven-ant-tasks-2.1.1.jar
>
> maven-ant-tasks-init:
>     [mkdir] Created dir: /home/paulchoi/rpm/SOURCES/apache-cassandra-0.7.3-src/build/lib
>
> BUILD FAILED
> /home/paulchoi/rpm/SOURCES/apache-cassandra-0.7.3-src/build.xml:155: name, file or resource
attribute of typedef is undefined
>
> Total time: 1 second
> [paulchoi@build02 apache-cassandra-0.7.3-src]$


--
Eric Evans
eevans@rackspace.com

Mime
View raw message