incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Harvey <alie...@gmail.com>
Subject Re: sstable2json not loading CLASSPATH properly?
Date Sun, 13 Mar 2011 10:54:13 GMT
It actually *is* in the default source, just not in the ubuntu
package. I sent a message over to the package maintainer about it.

Cheers,
Jason

On Mar 13, 3:22 am, Norman Maurer <nor...@apache.org> wrote:
> What about creating a bugreport and attach the needed changes. I bet
> cassandra devs love contributions....
>
> Bye
> Norman
>
> 2011/3/13, Jason Harvey <alie...@gmail.com>:
>
> > nvm, I found the problem. Sstable2json and json2sstable require a
> > log4j-tools properties file. I created one and all was well. I guess
> > that should be added to the default install packages.
>
> > Cheers,
> > Jason
>
> > On Sat, Mar 12, 2011 at 12:09 AM, Jason Harvey <alie...@gmail.com> wrote:
> >> Sstable2json always spits out the following when I execute it:
>
> >> log4j:WARN No appenders could be found for logger
> >> (org.apache.cassandra.config.DatabaseDescriptor).
> >> log4j:WARN Please initialize the log4j system properly.
>
> >> I verified that the run script sets the CLASSPATH properly, and I even
> >> tried manually setting CLASSPATH but still got no dice. Is
> >> sstable2json just not reading the CLASSPATH properly, or does it need
> >> a separate log2j config? Running 0.7.3 on Ubuntu.
>
> >> Thanks,
> >> Jason

Mime
View raw message