incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mcasandra <mohitanch...@gmail.com>
Subject Re: problem with bootstrap
Date Thu, 10 Mar 2011 19:22:16 GMT

mcasandra wrote:
> 
> 
> aaron morton wrote:
>> 
>> 
>> The issue I think you and Patrik are seeing occurs when you *remove*
>> nodes from the ring. The ring does not know if they are up or down. E.g.
>> you have a ring of 3 nodes, and add a keyspace with RF 3. Then for
>> whatever reason 2 nodes are removed from the ring. When bootstrapping a
>> node into this ring it will fail because it detects the cluster does not
>> have enough *endpoints* (different to up nodes) to support the keyspace. 
>> 
>> 
> Thanks for more info. However I am still not understanding why I am
> running in this situation since this node was once up like other node. In
> your previous post you mentioned that the node got removed. I am trying to
> understand what that really means and what causes a node to remove? All I
> did was kill -9 and then sudo cassandra to start the node.
> 
I am still trying to see how to find the root cause of this behaviour. I
wonder if this were to happen in production how will we debug or what will
we do :(

--
View this message in context: http://cassandra-user-incubator-apache-org.3065146.n2.nabble.com/problem-with-bootstrap-tp6127315p6158996.html
Sent from the cassandra-user@incubator.apache.org mailing list archive at Nabble.com.

Mime
View raw message