incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ran Tavory <ran...@gmail.com>
Subject Re: 0.7.0 mx4j, get attribute
Date Thu, 03 Feb 2011 16:29:24 GMT
Try adding this to the end of the URL: ?template=identity

On Thu, Feb 3, 2011 at 4:23 PM, Chris Burroughs
<chris.burroughs@gmail.com>wrote:

> On 02/02/2011 01:41 PM, Ryan King wrote:
> > On Wed, Feb 2, 2011 at 10:40 AM, Chris Burroughs
> > <chris.burroughs@gmail.com> wrote:
> >> I'm using 0.7.0 and experimenting with the new mx4j support.
> >>
> >> http://host:port
> /mbean?objectname=org.apache.cassandra.request%3Atype%3DReadStage
> >>
> >> Returns a nice pretty html page.  For purposes of monitoring I would
> >> like to get a single attribute as xml.  The docs [1] decribe a
> >> "getattribute" endpoint.  But I have been unable to get anything other
> >> than a blank response from that.  mx4j does not seem to include any
> >> logging for troubleshooting.
> >>
> >> Example:
> >> http://host:port
> /getattribute?objectname=org.apache.cassandra.request%3atype%3dReadStage&attribute=PendingTasks
> >>
> >> returns 200 OK with no data.
> >>
> >> If anyone could point out what embarrassingly simple mistake I am making
> >> I would be much obliged.
> >>
> >>
> >> [1] http://mx4j.sourceforge.net/docs/ch05.html
> >>
> >
> > Note that many objects in cassandra aren't initialized until they're
> > used for the first time.
> >
> > -ryan
>
> But if I can access them through jconsole just fine I don't see what
> would be stopping mx4j.
>



-- 
/Ran

Mime
View raw message