yes , i can resolve the problem using cygwin
but i want to know the reason for the problem , such as :
the MR can't recognize the type of OS or may be i should
configure it in the my word count? 

Bingbing Liu

发件人: CassUser CassUser
发送时间: 2010-12-03  07:38:32
收件人: user
主题: Re: Re: how can i ran the word count example on windows?
You can install cygwin in order to run mapred job locally on windows

On Thu, Dec 2, 2010 at 5:57 AM, Bingbing Liu <> wrote:
hi ,arron ,thanks for your reply
i run a single node cassandra instance on linux (IP:
but i run the word count in the eclipse on windows with seting the host ip =

Bingbing Liu

发件人: aaron morton
发送时间: 2010-12-02  19:04:13
收件人: user
主题: Re: how can i ran the word count example on windows?
chmod is used on linux to change the file permissions. It seems like hadoop links your on linux. 

What command are you running to get this error ? 


On 2 Dec 2010, at 21:03, Bingbing Liu wrote:

i use the same configuration in eclispe both on windows and linux , on linux ,it goes well, but on windows , it fails
here is the exception information:
10/12/02 10:53:40 INFO mapreduce.MRSelect: output reducer type: filesystem
10/12/02 10:53:40 INFO jvm.JvmMetrics: Initializing JVM Metrics with processName=JobTracker, sessionId=
Exception in thread "main" Cannot run program "chmod": CreateProcess error=2, ϵͳÕҲ»µ½ָ¶
at java.lang.ProcessBuilder.start(Unknown Source)
at org.apache.hadoop.util.Shell.runCommand(
at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(
at org.apache.hadoop.util.Shell.execCommand(
at org.apache.hadoop.util.Shell.execCommand(
at org.apache.hadoop.fs.RawLocalFileSystem.execCommand(
at org.apache.hadoop.fs.RawLocalFileSystem.setPermission(
at org.apache.hadoop.fs.FilterFileSystem.setPermission(
at org.apache.hadoop.fs.FileSystem.mkdirs(
at org.apache.hadoop.mapred.JobClient.configureCommandLineOptions(
at org.apache.hadoop.mapred.JobClient.submitJobInternal(
at org.apache.hadoop.mapreduce.Job.submit(
at org.apache.hadoop.mapreduce.Job.waitForCompletion(
at org.clouddb.cassandra.mapreduce.MRSelect.main(
Caused by: CreateProcess error=2, ϵͳÕҲ»µ½ָ¶
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
... 17 more

Bingbing Liu

发件人: Jeremy Hanna
发送时间: 2010-12-02  11:13:04
收件人: user
主题: Re: how can i ran the word count example on windows?
There isn't currently, but perhaps you could contribute one :).  If you take a look at the sh script in the bin directory of the word count example, it shouldn't be terribly difficult to mimic the behavior.  It's mostly just setting up the classpath and executing the Java class with some arguments.
On Dec 1, 2010, at 8:26 PM, Bingbing Liu wrote:

i don't know how to set the command line
is there a word_count.bat ? like the word_count in the bin on linux?

Bingbing Liu