seems to be a thrift failure, try to recompile thrift on your mac:

ClassNotFoundException: org.apache.cassandra.thrift.CassandraDaemon



2010/11/24 Alberto Velandia <betovelandia@gmail.com>
Hi I'm getting this error when i run bin/cassandra -f

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/cassandra/thrift/CassandraDaemon
Caused by: java.lang.ClassNotFoundException: org.apache.cassandra.thrift.CassandraDaemon
       at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
       at java.security.AccessController.doPrivileged(Native Method)
       at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
       at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:248)

which seems to be a Java version issue, I've updated my ~/.profile to the following:

export PATH="/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/bin:/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:$PATH"
[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"  # This loads RVM into a shell session.

but I'm still getting the same error, I've also set the environment variable JAVA_HOME but I don't know If I did it right.

can anyone help me? thx