In this case you could try subtracting 1 from the right hand side token. 

AFAIK the recommended approach to reading all rows in a CF is to use keys on the KeyRange see

Tokens are more of an internal feature there to support the Hadoop integration .

If you want to iterate over all keys in a CF try either using the approach linked above, or try Hadoop. 

Hope that helps. 

On 16 Nov, 2010,at 03:01 PM, Anand Somani <> wrote:

I only have 1 node (not a cluster), so not sure what another machine it is trying to send to? This is a very basic test that I am doing, hence only 1 node.

I use describe_ring to get a list of TokenRanges (1 in this case) and use the end_token and start_token from it to get_range_slices. So what should I be doing instead?

On Mon, Nov 15, 2010 at 5:34 PM, Jonathan Ellis <> wrote:
TimedOutException means the host that your client is talking to sent
the request to another machine, which threw the logged exception and
thus did not reply.

You're doing an illegal query; token-based queries have to be on
non-wrapping ranges (left token < right token), or a wrapping range of
(mintoken, mintoken).  This was changed as part of the range scan
fixes post-0.6.5.

On Mon, Nov 15, 2010 at 6:32 PM, Anand Somani <> wrote:
> Hi
> Problem:
>      Call - clientget_range_slices(). Using tokens (not keys), fails with
> TimedoutException which I think is misleading (Read on)
>      Server : Works with 6.5 server, but not with 6.6 or 6.8
>      Client: have tried both 6.5 and 6.6
> I am getting a TimedoutException when I do a get_range_slices() passing in
> tokens (not keys). I only have 1 node at this time. This is working with
> 6.5, but is broken in 6.6 and 6.8. Basically I see the exception below on
> the server side, so not sure how it translates to TimedoutException. I tried
> to play with setting the timeout, but keep getting the TimedOutException in
> exactly 10 seconds, the set value seems to have no impact.
> The exception on the server side:
> ERROR [ROW-READ-STAGE:4] 2010-11-15 22:55:39,261 (line
> 87) Uncaught exception in thread Thread[ROW-READ-STAGE:4,5,main]
> java.lang.AssertionError:
> (99318701746171979556028978387039718369,99318701746171979556028978387039718369]
>     at
> org.apache.cassandra.db.ColumnFamilyStore.getRangeSlice(
>     at
> org.apache.cassandra.service.RangeSliceVerbHandler.doVerb(
>     at
>     at
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
>     at
> java.util.concurrent.ThreadPoolExecutor$
>     at
> I am doing something wrong or what?
> Thanks
> Anand

Jonathan Ellis
Project Chair, Apache Cassandra
co-founder of Riptano, the source for professional Cassandra support