incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Evans <eev...@rackspace.com>
Subject Re: using SimpleAuthenticator is not working
Date Sun, 14 Nov 2010 16:10:01 GMT
On Fri, 2010-11-12 at 17:07 -0800, Alaa Zubaidi wrote:
> using SimpleAuthenticator is not working with me in beta 3
> 
> I am doing the following:
> 
> ·In Cassandra.yaml Set
> authenticator: org.apache.cassandra.auth.SimpleAuthenticator
> ·Add username and password to passwd.proprties
> ·Add username to keyspace and column family permission in
> access.proprties
> ·Add the path for passwd.proprties and access.proprties to
> Cassandra.bat
> set CASSANDRA_PARAMS=-Dcassandra -Dcassandra-foreground=yes
> -Dpasswd.properties=E:\Cassandra\Cass07b3\apache-cassandra-0.7.0-beta3
> \conf\passwd.properties 
> 
> -Daccess.properties=E:\Cassandra\Cass07b3\apache-cassandra-0.7.0-beta3
> \conf\access.properties 

Did you set authority to org.apache.cassandra.auth.SimpleAuthority?

> ·Use login() to login to Cassandra in the application:
> Map<String, String> creds = new HashMap<String, String>();
> creds.put("user1", "pwd1");
> AuthenticationRequest Auth = newAuthenticationRequest(creds);
> _client.login(Auth);
> 
> its giving me an error, with no message, and if I try to do any thing 
> its giving me "I am not logged in" error.
> Is there any thing I am missing? 

Make sure to set the logging level to DEBUG; there should be something
in the logs.

-- 
Eric Evans
eevans@rackspace.com


Mime
View raw message