I normally get the source download, then run ant gen-thrift-py 

Is there a reason you want to build it manually?

Aaron
 

On 22 Sep, 2010,at 07:35 PM, Shashank Tiwari <tshanky@gmail.com> wrote:

I installed thrift successfully on Snow Leaopard. However, when I run 
thrift -gen java interface/cassandra.thrift with Cassandra 0.6.5, I get an error which reads as follows:
....apache-cassandra-0.6.5/interface/cassandra.thrift:303] error: identifier ONE is unqualified!
Line 303 of cassandra.thrift is highlighted in the text below:

296   /**
297     Get the Column or SuperColumn at the given column_path. If no value is present, NotFoundException is thrown    . (This is
298     the only method that can throw an exception under non-failure conditions)
299    */
300   ColumnOrSuperColumn get(1:required string keyspace,
301                           2:required string key,
302                           3:required ColumnPath column_path,
303                           4:required ConsistencyLevel consistency_level=ONE)
304                       throws (1:InvalidRequestException ire, 2:NotFoundException nfe, 3:UnavailableException ue    , 4:TimedOutException te),
305 

Could somebody please help resolve this problem and also explain what's going on here.

Thanks, Shashank