Unfortunately, I'm running Cassandra on Windows platform and the logging doesn't work; I'm not able to configure them properly respectively.
I always get "log4j:WARN No appenders could be found for logger (org.apache.cassandra.utils.CLibrary)." after Cassandra starts. I tried to copy "log4j-server.properties" to Cassandra home directory, to /bin directory, to /lib directory, but the file still cannot be found :(
I'm using Cassandra.bat file to run them...

Augi


2010/9/23 Sylvain Lebresne <sylvain@yakaz.com>
You should not have anything special to do.
Could you check the cassandra logs and give us the stack trace of the error ?

--
Sylvain

On Thu, Sep 23, 2010 at 8:36 AM, Michal Augustýn
<augustyn.michal@gmail.com> wrote:
> Hello,
> I tried to use Column.Ttl property but I was not successful. My simple test:
> 1) insert column with ttl = 3
> 2) get column - all is ok
> 3) wait for 2 seconds
> 4) get column - all is ok
> 5) wait again for 2 seconds (so column should disappear)
> 6) get column - I got "Thrift.TApplicationException" of type 6 with message
> "Internal error processing get"
> Do I have to change some Cassandra configuration in order to get ttl
> working? Or am I doing anything in bad way?
> Thank you!
> Augi