Just took a look upgrading from from 31/08 nightly to the 20/09 and noticed the news.txt says...

"The Cassandra inter-node protocol is incompatible with 0.6.x releases (and with 0.7 beta1)"

Could someone point me to the ticket(s) for this change so I can see if I can do a rolling upgrade. 

Thanks
Aaron