Check the logs for errors and run nodetool streams to see if it's moving data around. 


On 27 Aug, 2010,at 09:53 AM, Mark <> wrote:

I have a 2 node cluster (testing the waters) w/ a replication factor
of 2. One node got completed screwed up (see any of my previous messages
from today) so I deleted the commit log and data directory. I restarted
the node and rain nodetool repair as describe in I waited for over an hour
and checked my ring only to find that nothing was repaired/replicated???
I only have a mere 7gigs of data so I would have thought this would have
been fairly quick?

Address Status State Load Token

x.x.x.x Up Normal 7.31 GB
x.x.x.x Up Normal 30.01 MB

I tried the alternative method of manually removing the token and then
bootstrapping however when I tried to remove the token via nodetool
removetoken an IllegalStateException was thrown... "replication factor
(2) exceeds number of endpoints (1)"

What should I do in this situation to get my node back up to where it
should be? Is there anywhere I can check that the repair is actually

Thanks for any suggestions

ps I'm using 0.7.0 beta 1