I just loaded cassandra in eclipse and noted that the client code uses jline which does not work in eclipse ( a known issue).
 
Are there any plans to either update jline or patch this issue. I noticed that this has been logged a few times to jline. The jline code has not been updated since 2008 I believe and is unlikely to have any updates. Maybe there are other plans for cassandra that negate the need for jline ?
 
I don't really need jline / eclipse but figured others might be interested. If I find / stumble across the fix and others have not advised on this I will advise the list.