incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Molinaro <antho...@alumni.caltech.edu>
Subject Re: Bootstrap question
Date Fri, 16 Jul 2010 05:45:08 GMT
Okay, so things were pretty messed up.  I shut down all the new nodes,
then the old nodes started doing the half the ring is down garbage which
pretty much requires a full restart of everything.  So I had to shut
everything down, then bring the seed back, then the rest of the nodes,
so they finally all agreed on the ring again.

Then I started one of the new nodes, and have been watching the logs, so
far 2 hours since the "Bootstrapping" message appeared in the new
log and nothing has happened.  No anticompaction messages anywhere, there's
one node compacting, but its on the other end of the ring, so no where near
that new node.  I'm wondering if it will ever get data at this point.

Is there something else I should try?  The only thing I can think of
is deleting the system directory on the new node, and restarting, so
I'll try that and see if it does anything.

-Anthony

On Thu, Jul 15, 2010 at 03:43:49PM -0500, Jonathan Ellis wrote:
> On Thu, Jul 15, 2010 at 3:28 PM, Anthony Molinaro
> <anthonym@alumni.caltech.edu> wrote:
> > Is the fact that 2 new nodes are in the range messing it up?
> 
> Probably.
> 
> >  And if so
> > how do I recover (I'm thinking, shutdown new nodes 2,3,4,5, the bringing
> > up nodes 2,4, waiting for them to finish, then bringing up 3,5?).
> 
> Yes.
> 
> You might have to restart the old nodes too to clear out the confusion.
> 
> -- 
> Jonathan Ellis
> Project Chair, Apache Cassandra
> co-founder of Riptano, the source for professional Cassandra support
> http://riptano.com

-- 
------------------------------------------------------------------------
Anthony Molinaro                           <anthonym@alumni.caltech.edu>

Mime
View raw message