incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ran Tavory <ran...@gmail.com>
Subject Re: decommission and org.apache.thrift.TApplicationException: get_slice failed: unknown result
Date Thu, 20 May 2010 06:34:04 GMT
My decommission was progressing OK, although very slow, but I'll send
another question to the list about that...
The exception must be a hiccup, I hope I won't get it again I suppose...

On Tue, May 18, 2010 at 4:10 PM, Gary Dusbabek <gdusbabek@gmail.com> wrote:

> If I had to guess, I'd say that something at the transport layer had
> trouble.  Possibly some kind of thrift hiccup that we haven't seen
> before.
>
> Your description makes it sound as if the decommission is proceeding
> normally though.
>
> Gary.
>
> On Tue, May 18, 2010 at 04:42, Ran Tavory <rantav@gmail.com> wrote:
> > What's the correct way to remove a node from a cluster?
> > According to this page http://wiki.apache.org/cassandra/Operations a
> > decommission call should be enough.
> > When decommissioning one of the nodes from my cluster I see an error in
> the
> > client:
> > org.apache.thrift.TApplicationException: get_slice failed: unknown result
> >        at
> >
> org.apache.cassandra.thrift.Cassandra$Client.recv_get_slice(Cassandra.java:407)
> >        at
> >
> org.apache.cassandra.thrift.Cassandra$Client.get_slice(Cassandra.java:367)
> >
> > The client isn't talking to the decommissioned node, it's connected to
> > another node, so I'd expect all operations to continue as normal
> (although
> > slower), right?
> > I simply called "nodetool -h ... decommission" on the host and waited.
> After
> > a while, while the node is still decommissioning I saw the error at the
> > client.
> > The current state of the node is Decommissioned and it's not in the ring
> > now. It is still moving streams to other hosts, though. I can't be sure,
> > though whether the error happened during the time it was Leaving the ring
> or
> > was it already Decommissioned.
> > The server logs don't show something of note (no errors or warnings).
> > What do you think?
>

Mime
View raw message