incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guilherme Kaster <guilherme.kas...@auspex.com.br>
Subject Problem using get_range_slices
Date Wed, 21 Apr 2010 19:19:47 GMT
I've encountered a problem on cassandra 0.6 while using get_ranged_slices.
I use RP and when I use get_range_slices the keys are not returned in an
"ordered" maner, that means the last key on the list not always the
"greater" key in the list, so I started getting repetitions and ONCE entered
in an infinite loop because the last key on the list was the same start key
I used (keys are inclusive). So a dig a little in cassandra code and found
where keys are converted to tokens in RP (FBUtilities.hash) and started
using tokens, which are not inclusive, starting with token 0. That solved
one of my problems. But the keys where still not returned ascending in
order. I converted them to tokens but the tokens are also not in order. So I
now use as the "new" start token of the next iteration of get_range_slices
the "greater" token (converted from key) found in the returned list.

Is that correct? Has anyone else had the same problem?

-- 
Guilherme L. Kaster
Auspex Desenvolvimento de Negócios em Tecnologia Ltda.

Mime
View raw message