incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesus Ibanez <jesusiba...@gmail.com>
Subject Re: Running on Windows
Date Tue, 16 Mar 2010 04:53:27 GMT
Im sorry Jonathan. I didn't know it was the cli, I thought the problem was
with cassandra.bat becouse it doesn't show the output: Starting up server...
Instead, it shows: Starting up server gossip...

But the problem was in the cassandra-cli.bat.

The nice new is that know we know that we have to modify the
cassandra-cli.bat file. :)


2010/3/16 Jonathan Ellis <jbellis@gmail.com>

> Your time on IRC would have been a lot more productive if you had
> mentioned that bin\cassandra was working fine and you were stuck on
> the cli. :(
>
> On Mon, Mar 15, 2010 at 11:41 PM, Jesus Ibanez <jesusibasim@gmail.com>
> wrote:
> > To run Cassandra on Windows, after executing bin\cassandra without
> problems,
> > we need to insert the line if NOT DEFINED CASSANDRA_HOME set
> > CASSANDRA_HOME=%CD% into the cassandra-cli.bat file before we execute it.
> > That line is missing in cassandra-cli.bat, so add it and Cassandra will
> > execute perfectly!
> > .
> > .
> > .
> > SETLOCAL
> > if NOT DEFINED CASSANDRA_HOME set CASSANDRA_HOME=%CD%
> > SET CASSANDRA_LIBS=%CASSANDRA_HOME%\lib
> > FOR %%a IN (%CASSANDRA_HOME%\lib\*.jar) DO  call :append %%~fa
> > java -cp %CASSANDRA_LIBS% org.apache.cassandra.cli.CliMain
> > .
> > .
> > .
> > Someone please tell the developers about this bug.
> > Michael was the one who find it out.
> > Bye!
>

Mime
View raw message