incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Christophe Praud ...@praud.com>
Subject cassandra-cli 0.6 displays hashcodes instead of column names
Date Mon, 22 Mar 2010 19:20:19 GMT
Hi all,

I've got a problem since upgrading to Cassandra 0.6beta2/3. Instead of:

cassandra> get test1.tags['5464']
=> (column=width, value=500, timestamp=1268918427)
=> (column=transparent_color, value=000000, timestamp=1268918427)
=> (column=resolution, value=96x96, timestamp=1268918427)
=> (column=quality, value=75, timestamp=1268918427)
=> (column=interlace, value=None, timestamp=1268918427)
=> (column=height, value=333, timestamp=1268918427)
=> (column=compression, value=JPEG, timestamp=1268918427)
=> (column=colorspace, value=RGB, timestamp=1268918427)
=> (column=colordepth, value=8-bit, timestamp=1268918427)
=> (column=background_color, value=FFFFFF, timestamp=1268918427)

I get:

cassandra> get test1.tags['5464']
=> (column=7769647468, value=500, timestamp=1268918427)
=> (column=7472616e73706172656e745f636f6c6f72, value=000000,
timestamp=1268918427)
=> (column=7265736f6c7574696f6e, value=96x96, timestamp=1268918427)
=> (column=7175616c697479, value=75, timestamp=1268918427)
=> (column=696e7465726c616365, value=None, timestamp=1268918427)
=> (column=686569676874, value=333, timestamp=1268918427)
=> (column=636f6d7072657373696f6e, value=JPEG, timestamp=1268918427)
=> (column=636f6c6f727370616365, value=RGB, timestamp=1268918427)
=> (column=636f6c6f726465707468, value=8-bit, timestamp=1268918427)
=> (column=6261636b67726f756e645f636f6c6f72, value=FFFFFF,
timestamp=1268918427)
Returned 10 results.

Both queries were run on the same cluster, with CLI 0.5.1 and 0.6 resp.
The cluster is a 0.6 version, but the data were set in a version 0.5.1
before I upgraded the server to 0.6beta2.
New columns I set have the same problem, too.

Getting invidually each value works, but with the same display problem:

cassandra> get test1.tags['5464']['compression']
=> (column=636f6d7072657373696f6e, value=JPEG, timestamp=1268918427)


Also I may have broken something, as I had to copy some missing jars from
0.5.1/lib to 0.6beta3/lib.

I had the same problems with version 0.6beta2.



Regards,



-- 
Jean-Christophe Praud         -      http://shub-niggurath.com
Ph'nglui mglw'nafh Cthulhu n'gah Bill R'lyeh Wgah'nagl fhtagn!

Mime
View raw message