incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaakko <rosvopaalli...@gmail.com>
Subject Re: Potential problem with 0.5 branch (Possibly in gossiping?)
Date Wed, 23 Dec 2009 00:43:28 GMT
Hi,

Which revision number you are running?

Can you see any log lines related to node being UP or dead? (like
"InetAddress X.X.X.X is now dead" or "Node X.X.X.X has restarted, now
UP again"). These messages come from the Gossiper and indicate if it
for some reason thinks the node is dead. Level of these messages is
info.

Another thing is: can you see any log messages like "Node X.X.X.X
state normal, token XXX"? These are on debug level.

-Jaakko


On Wed, Dec 23, 2009 at 12:59 AM, Ramzi Rabah <rrabah@playdom.com> wrote:
> I just recently upgraded to latest in 0.5 branch, and I am running
> into a serious issue. I have a cluster with 4 nodes, rackunaware
> strategy, and using my own tokens distributed evenly over the hash
> space. I am writing/reading equally to them at an equal rate of about
> 230 reads/writes per second(and cfstats shows that). The first 3 nodes
> are seeds, the last one isn't. When I start all the nodes together at
> the same time, they all receive equal amounts of reads/writes (about
> 230).
> When I bring node 4 down and bring it back up again, node 4's load
> fluctuates between the 230 it used to get to sometimes no traffic at
> all. The other 3 still have the same amount of traffic. And no errors
> what so ever seen in logs. Any ideas what can be causing this
> fluctuation on node 4 after I restarted it?
>

Mime
View raw message