incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Zlatanov <>
Subject Re: [ANNOUNCE] Cassandra.gem 0.5
Date Wed, 11 Nov 2009 21:22:37 GMT
On Thu, 20 Aug 2009 14:37:55 -0700 Evan Weaver <> wrote: 

EW> The Cassandra client gem 0.5 for Ruby is released!
EW> Highlights since the last ANNOUNCE:
EW>   - gem name changed from cassandra_client to cassandra
EW>   - bin/cassandra_helper script, to build and start the server for you
EW>   - working temporal comparators, including RFC-compliant UUID type
EW>   - many API changes, for usability
EW>   - complete documentation

EW> This is the first version I would be comfortable using in production,
EW> which is saying something.

EW> To install, run: sudo gem install cassandra

EW> Documentation is here:

Thanks for this package.  I tried it without much Ruby experience on
Ubuntu.  The 'rubygems' package was required.  I also needed the
'libopenssl-ruby' package, but there was no way to tell it was required
during the installation.  After install, cassandra_helper complained
that net/https was missing and that was the only hint I had that
libopenssl-ruby needed to be installed.

Apparently all the binaries get installed into either ~/.gem or
/var/lib/gems, silently, depending on whether root or a user is running.
This is a bit annoying (not your fault, of course) as I had to do

CASSANDRA_INCLUDE=/home/tzz/workspace/Cassandra PATH=/home/tzz/.gem/ruby/1.8/bin:/var/lib/gems/1.8/bin:${PATH}

just to run the helper.  This maybe should be mentioned in the docs;
right now they just say to use bin/cassandra_helper.

The build_cassandra command worked great.  Starting cassandra, however,
gave me:

CASSANDRA_INCLUDE=/home/tzz/workspace/Cassandra PATH=/home/tzz/.gem/ruby/1.8/bin:/var/lib/gems/1.8/bin:${PATH}
cassandra_helper cassandra
(in /home/tzz/.gem/ruby/1.8/gems/cassandra-
mkdir -p /home/tzz/cassandra/test
[: 46: -o: unexpected operator
Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-options] -jar jarfile [args...]
           (to execute a jar file)

... (java help output cut) ...

I'm using zsh, perhaps that's the issue.  I didn't debug it further
right now but will look further if it's not obvious to you where the
problem is.


View raw message