incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tyler Hobbs <ty...@datastax.com>
Subject Re: CQL 3 Binary protocol spec mismatch
Date Thu, 15 Aug 2013 15:43:38 GMT
Can you also describe the query you're running and paste the actual entire
binary response (from the header to the end)?

By the way, are you writing a new client?


On Wed, Aug 14, 2013 at 6:37 PM, Mosfeq Rashid <mosfeq-cassandra@madrose.net
> wrote:

>
> Thanks for the quick response.
>
> This is what I am getting:
>
> <row-count><value-col1-len><value-col1><value-col2-len><value-col2><value-col1-len><value-col1>...
>
> As you see, there is no metadata before the row-count.
>
> All the others messages I have tried like create, error, etc. are sending
> response as expected in the spec.
>
> By I am running Ubuntu 13.04 and the binary distribution.
>
> --
> Mosfeq
>
> At Wed, 14 Aug 2013 18:09:39 -0500,
> Tyler Hobbs <tyler@datastax.com> wrote:
> >
> > Can you provide more details on exactly what's being returned?  As far
> as I
> > know, ResultMessages of type "ROWS" should always start with metadata,
> and
> > I haven't seen a case where it's missing in 1.2.
> >
> >
> > On Wed, Aug 14, 2013 at 6:05 PM, Mosfeq Rashid <
> mosfeq-cassandra@madrose.net
> > > wrote:
> >
> > >
> > > The response to the Select query is supposed to have metadata before
> row
> > > data is provided.  But in case of C* 1.2.5 and 1.2.8, I only get the
> row
> > > data.  As far as I understand binary protocol, the message should have
> all
> > > the data to parse it.  Does anyone know what I am missing?
> > >
> > > --
> > > Mosfeq
> > >
> > >
> >
> >
> > --
> > Tyler Hobbs
> > DataStax <http://datastax.com/>
>



-- 
Tyler Hobbs
DataStax <http://datastax.com/>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message