incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Kjellman <>
Subject Re: C* 1.2.2 vs Raspberry Pi
Date Mon, 04 Mar 2013 19:24:59 GMT
This was due to

Should be safe to remove this when running on a you Raspberry Pi as it is
a performance change for the JVM and I guess not supported on whatever
version is supported on your distro for the Pi.


On 3/4/13 11:17 AM, "Andrew Cobley" <> wrote:

>Stupidly I've locked myself out of JIRA and it doesn't seem to want to
>send me a password reset so I'll send this bug report here.
>As you guys may know I'v been running C* on a  Raspberry Pi cluster for
>experimental and educational reasons.  It seems the startup script is
>borked for 1.2.2 when using JDK1.8 (early release) on the PI.
>In  lines 206-208
>if [ "$JVM_VERSION" \> "1.7" ] ; then
>    JVM_OPTS="$JVM_OPTS -XX:+UseCondCardMark"
>Are causing C* to not start on the Pi.  It's reporting :
>Unrecognized VM option 'UseCondCardMark'
>Error: Could not create the Java Virtual Machine.
>Error: A fatal exception has occurred. Program will exit.
>It looks like this change came in for 1.2.2
>Andy Cobley
>School of Computing
>University of Dundee
>The University of Dundee is a registered Scottish Charity, No: SC015096

Copy, by Barracuda, helps you store, protect, and share all your amazing
things. Start today:

View raw message