incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Kjellman <mkjell...@barracuda.com>
Subject Re: Proposal: require Java7 for Cassandra 2.0
Date Wed, 06 Feb 2013 22:29:17 GMT
There seems to be a lot of confusion on this topic in the C* Community.
Most people look at the Datastax docs that recommend Java 6 and ask why
that recommendation is there. Threads never seem to "finish" with a clear
definitive answer. There seem to be about 3-4 of these for the past few
months on the Users list.

I love the idea of requiring Java 7 explicitly + clarifying the project's
stance on the JVM requirement overall.

Might also want to lock it down to something like >Java 7 u8 (u13 might be
even nicer given 2.0's timeframe) given the early instability in Java7's
early releases (and I guess allow but maybe warn for OpenJDK7?).

My 2-cents.

Best,
Michael

On 2/6/13 2:21 PM, "Jonathan Ellis" <jbellis@gmail.com> wrote:

>Java 6 EOL is this month.  Java 7 will be two years old when C* 2.0
>comes out (July).  Anecdotally, a bunch of people are running C* on
>Java7 with no issues, except for the Snappy-on-OS-X problem (which
>will be moot if LZ4 becomes our default, as looks likely).
>
>Upgrading to Java7 lets us take advantage of new (two year old)
>features as well as simplifying interoperability with other
>dependencies, e.g., Jetty's BlockingArrayQueue requires java7.
>
>Thoughts?
>
>-- 
>Jonathan Ellis
>Project Chair, Apache Cassandra
>co-founder, http://www.datastax.com
>@spyced


Mime
View raw message