incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Ellis <jbel...@gmail.com>
Subject Proposal: require Java7 for Cassandra 2.0
Date Wed, 06 Feb 2013 22:21:54 GMT
Java 6 EOL is this month.  Java 7 will be two years old when C* 2.0
comes out (July).  Anecdotally, a bunch of people are running C* on
Java7 with no issues, except for the Snappy-on-OS-X problem (which
will be moot if LZ4 becomes our default, as looks likely).

Upgrading to Java7 lets us take advantage of new (two year old)
features as well as simplifying interoperability with other
dependencies, e.g., Jetty's BlockingArrayQueue requires java7.

Thoughts?

-- 
Jonathan Ellis
Project Chair, Apache Cassandra
co-founder, http://www.datastax.com
@spyced

Mime
View raw message