incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brandon Williams <dri...@gmail.com>
Subject Re: Proposal: require Java7 for Cassandra 2.0
Date Wed, 06 Feb 2013 22:29:04 GMT
On Wed, Feb 6, 2013 at 4:21 PM, Jonathan Ellis <jbellis@gmail.com> wrote:
> Java 6 EOL is this month.  Java 7 will be two years old when C* 2.0
> comes out (July).  Anecdotally, a bunch of people are running C* on
> Java7 with no issues, except for the Snappy-on-OS-X problem (which
> will be moot if LZ4 becomes our default, as looks likely).
>
> Upgrading to Java7 lets us take advantage of new (two year old)
> features as well as simplifying interoperability with other
> dependencies, e.g., Jetty's BlockingArrayQueue requires java7.
>
> Thoughts?

We already do quite a bit of jdk version/type detection in
cassandra-env.sh so we can catch it early if they try to use java6 and
give a meaningful error, so this sounds good to me.

-Brandon

Mime
View raw message