incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Radim Kolar <...@sendmail.cz>
Subject Re: [VOTE] Release Apache Cassandra 1.0.3
Date Mon, 14 Nov 2011 12:08:19 GMT
I'm not sure why hints are not working for you. You might have hit some 
other issue. Some suggestions:

1. Verify that HintsColumnFamily actually contains some data with 
cassandra-cli and "list HintsColumnFamily"
yes

> 2. Try restarting the node containing the hints to check if that gets 
> your hints delivered (gossip state related issue?).
  INFO [HintedHandoff:1] 2011-11-14 12:35:15,557 
HintedHandOffManager.java (line 334) Finished hinted handoff of 0 rows 
to endpoint /***99.40
Worked. This is improvement. at least node tried to deliver hints. So 
conclusion was that keeping gossip state still has some issues?

3. but hints table is not empty after that. majority of hints 
disappeared but this was left in table. Take a look at it.

[default@system] list HintsColumnFamily;
Using default limit of 100
-------------------
RowKey: 4241c76b735b154119e2dd3000000000
=> (super_column=9b7873500eb411e10000b1504fb874bb,
      (column=6b6579, value=4f6e646120436869726f, 
timestamp=1321270466319, ttl=864000)
      (column=6d75746174696f6e, 
value=000a72617069647368617265000a4f6e646120436869726f00000001000003ea01000003ea800000008000000000000000000000010007726573756c74730200093a804eca37420004b1b040cb9598000000080000000000000000,

timestamp=1321270466309, ttl=864000)
      (column=7461626c65, value=72617069647368617265, 
timestamp=1321270466319, ttl=864000)
      (column=76657273696f6e, value=00000003, timestamp=1321270466319, 
ttl=864000))
=> (super_column=9d7a84e00eb411e10000b1504fb874bb,
      (column=6b6579, value=7069676c6574, timestamp=1321270469678, 
ttl=864000)
      (column=6d75746174696f6e, 
value=000a7261706964736861726500067069676c657400000001000003e901000003e94ec0fcc50004b1b040fef5f000000000,

timestamp=1321270469678, ttl=864000)
      (column=7461626c65, value=72617069647368617265, 
timestamp=1321270469678, ttl=864000)
      (column=76657273696f6e, value=00000003, timestamp=1321270469678, 
ttl=864000))

1 Row Returned.
Elapsed time: 5 msec(s).

Mime
View raw message