incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Ellis <jbel...@gmail.com>
Subject Re: 2 problems running Cassandra as a developper
Date Sat, 14 Nov 2009 15:43:54 GMT
ant test
nosetests

On Sat, Nov 14, 2009 at 9:12 AM, Paul Sabou <paul.sabou@gmail.com> wrote:
> Hi,
>
> Thank you for your quick answer. Now it works. You are perfectly right.
>
> On Sat, Nov 14, 2009 at 3:23 PM, Jonathan Ellis <jbellis@gmail.com> wrote:
>
>> first just get it working: ant; bin/cassandra -f
>>
>> the EOF during recovery looks like you are trying to run trunk against
>> 0.4 commitlog files, which doesn't work (flush the 0.4 install first
>> to clean out commit logs)
>>
>
>
> What happened :
> (1) cassandra uses two places to store stuff (log's, commit logs, etc.) :
> - "/var/lib/cassandra"
> - "/var/log/cassandra"
> (2) before downloading the trunk I have installed the cassandra binary
> (version 0.4) and runned it
> (3) cassandra (0.4) dumbed some commit logs in those directories
> (4) i downloaded the source files from trunk that belong to a version > 0.4
> (5) when I tried to run it from eclipse (from the main class) it tried to
> reload the commit logs from the two directories ("/var/lib/cassandra" and
> "/var/log/cassndra") but because the log files had an old format (0.4
> format) => it crashed
>
> After i have deleted the commit log files I can start it from main. Great.
>
> What can I do to run the tests?
>
>
> best regards
> Paul.
>
>
>
>>
>> On Sat, Nov 14, 2009 at 8:10 AM, Paul Sabou <paul.sabou@gmail.com> wrote:
>> > Hi,
>> >
>> > Thank you for the advice. I have reimported the Eclipse project as a
>> > standard JAVA project and builded it again with ant and both problems
>> still
>> > persist.
>> >
>> >
>> > In the first case (not beeing able to run from main) it seems that it is
>> > missing some files from where it want to deserialise something
>> > (I assume the RecoveryManager -> CommitLog looks for some log files that
>> > store serialized objects) and it seems that the log files are not there.
>> >
>> >
>> > What can I do to make it work? Should I try another IDE (like Idea) or
>> what?
>> > It seems to be a rather trivial problem and any new developper interested
>> in
>> > Cassandra will run in the same problems when trying to run it in
>> > Eclipse/Linux.
>> >
>> > Any help/suggestion is appreciated.
>> >
>> > best regards
>> > Paul.
>> >
>> >
>> >
>> > On Sat, Nov 14, 2009 at 2:06 PM, Jonathan Ellis <jbellis@gmail.com>
>> wrote:
>> >
>> >> It's not a maven project.  It just has a pom.xml to help other project
>> >> that do use maven and want cassandra as a dependency.  Looks like
>> >> importing it as a maven project results in an incomplete build.
>> >>
>> >> On Sat, Nov 14, 2009 at 6:01 AM, Paul Sabou <paul.sabou@gmail.com>
>> wrote:
>> >> > Hi,
>> >> >
>> >> > I'am new to Cassandra. I'am trying to run it in Eclipse and I seems
to
>> >> > fail because some trivial reasons.
>> >> >
>> >> > I have an Ubuntu 9.04 and I use MyEclipse.
>> >> > I have checked out Cassandra from SVN and after I have installed
>> >> > thrift I could run the
>> >> > nosetests script succesfully.
>> >> >
>> >> > I have imported the trunk folder into MyEclipse with the following
>> steps
>> >> :
>> >> > (1) runned "mvn eclipse:eclipse" in the trunk folder
>> >> > (2) imported the project as an existing maven project
>> >> >
>> >> > and everything is ok up to here.
>> >> >
>> >> > I want to do two things now with the Cassandra project (that don't
>> >> > work) in MyEclipse :
>> >> >
>> >> > (1) I want to run it from main :
>> >> > - I followed the IDE instructions from
>> >> > http://wiki.apache.org/cassandra/HowToContribute
>> >> > running  "org.apache.cassandra.service.CassandraDaemon" class  with
>> >> > the following VM arguments : "-ea -Xmx1G -Dstorage-config=conf
>> >> > -Dcassandra-foreground"
>> >> > - I get the following stack trace :
>> >> >
>> >> > --------------------------------------------
>> >> > Exception encountered during startup.
>> >> > java.io.EOFException
>> >> >        at java.io.DataInputStream.readFully(DataInputStream.java:180)
>> >> >        at java.io.DataInputStream.readUTF(DataInputStream.java:592)
>> >> >        at java.io.DataInputStream.readUTF(DataInputStream.java:547)
>> >> >        at
>> >>
>> org.apache.cassandra.db.ColumnFamilySerializer.readComparator(ColumnFamilySerializer.java:115)
>> >> >        at
>> >>
>> org.apache.cassandra.db.ColumnFamilySerializer.deserialize(ColumnFamilySerializer.java:98)
>> >> >        at
>> >>
>> org.apache.cassandra.db.RowMutationSerializer.defreezeTheMaps(RowMutation.java:310)
>> >> >        at
>> >>
>> org.apache.cassandra.db.RowMutationSerializer.deserialize(RowMutation.java:320)
>> >> >        at
>> >>
>> org.apache.cassandra.db.RowMutationSerializer.deserialize(RowMutation.java:1)
>> >> >        at
>> org.apache.cassandra.db.CommitLog.recover(CommitLog.java:327)
>> >> >        at
>> >>
>> org.apache.cassandra.db.RecoveryManager.doRecovery(RecoveryManager.java:65)
>> >> >        at
>> >>
>> org.apache.cassandra.service.CassandraDaemon.setup(CassandraDaemon.java:90)
>> >> >        at
>> >>
>> org.apache.cassandra.service.CassandraDaemon.main(CassandraDaemon.java:166)
>> >> >
>> >> > ----------------------------------------------
>> >> >
>> >> > It seems that the RecoveryManager doesn't work as it was expected =>
>> >> > if I comment the line 90 in CassandraDaemon.java
>> >> > "recoveryMgr.doRecovery();" everything starts up correctly.
>> >> >
>> >> > I think I'am missing some config file or something similar. Can you
>> >> > please tell me what should I do?
>> >> >
>> >> > (2) I want to run the test suite :
>> >> > - When I run the test suite many tests fail with something like :
>> >> > -----------------------------------------------
>> >> > java.lang.NoClassDefFoundError: Could not initialize class
>> >> > org.apache.cassandra.config.DatabaseDescriptor
>> >> >        at
>> >> org.apache.cassandra.db.Table$TableMetadata.<clinit>(Table.java:70)
>> >> >        at org.apache.cassandra.db.Table.<init>(Table.java:354)
>> >> >        at org.apache.cassandra.db.Table.open(Table.java:184)
>> >> >        at
>> >>
>> org.apache.cassandra.db.RemoveSuperColumnTest.testRemoveSuperColumn(RemoveSuperColumnTest.java:43)
>> >> >        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> >> >        at
>> >>
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> >> >        at
>> >>
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> >> >        at java.lang.reflect.Method.invoke(Method.java:597)
>> >> >        at
>> >>
>> org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
>> >> >        at
>> >>
>> org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
>> >> >        at
>> >>
>> org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
>> >> >        at
>> >>
>> org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
>> >> >        at
>> >>
>> org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
>> >> >        at
>> >>
>> org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:31)
>> >> >        at
>> >>
>> org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:70)
>> >> >        at
>> >>
>> org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:44)
>> >> >        at
>> >> org.junit.runners.ParentRunner.runChildren(ParentRunner.java:180)
>> >> >        at
>> org.junit.runners.ParentRunner.access$000(ParentRunner.java:41)
>> >> >        at
>> >> org.junit.runners.ParentRunner$1.evaluate(ParentRunner.java:173)
>> >> >        at
>> >>
>> org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
>> >> >        at
>> >>
>> org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:31)
>> >> >        at org.junit.runners.ParentRunner.run(ParentRunner.java:220)
>> >> >        at
>> >>
>> org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:45)
>> >> >        at
>> >>
>> org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
>> >> >        at
>> >>
>> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460)
>> >> >        at
>> >>
>> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
>> >> >        at
>> >>
>> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
>> >> >        at
>> >>
>> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)
>> >> > -----------------------------------------------
>> >> >
>> >> >
>> >> > I think that this is also my fault for not putting the right config
>> >> > file in the right place. Can you please tell me what to do?
>> >> >
>> >> >
>> >> > best regards
>> >> > Paul.
>> >> >
>> >>
>> >
>>
>

Mime
View raw message