incubator-cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Ellis <>
Subject Re: Fixing the data model names
Date Wed, 12 Aug 2009 18:52:48 GMT
My brief two cents:

I think terminology + api changes need to be a big improvement to be
worth breaking things at this point, and I don't think this proposal
meets that bar.  In fact I'm not sure any proposal could.

On the specifics:

* Keyspace vs Database

Actually the right concept from the rdb world is "schema."  (Maybe it
is a mysql-ism to call these "databases?")

I deliberately avoided that term though, possibly mistakenly.

* ColumnFamily vs Record collection

-1.  CF correctly implies "group of columns" to me without being so
generic it could apply to anything.

* Record vs Row

I don't really care, I guess, but row never really seemed confusing to me.

* Column vs Attribute

Definitely -1 on this too.  Both imply "a named value" but column is
from the database world but attribute is from OO.  The connotations
are wrong.  Here the baggage from a relational background is mostly
correct.  As Evan notes the difference is that ColumnFamilies are
sparse, but that is a difference between CFs and Tables not between
the different concepts of Columns per se.

* SuperColumn vs Attribute Collection

SuperColumn is probably the worst name here, but calling it a
ColumnCollection would not be an improvement.  (I can have a
Collection<Column> in my own code, and do, but that is not the same
thing at all.)

So having thought it through I think I would have to say I think the
current names, if not perfect, are underrated.  Even if making the
change were free, and it's obviously not, I would prefer the existing


View raw message