incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Grieve <agri...@chromium.org>
Subject Re: Getting Crash in Mobile-spec file tests on iOS 2.1.0rc2
Date Wed, 05 Sep 2012 18:53:32 GMT
In the case I was hitting, it was a pretty obvious forgetting to nil check
error. Fix commit:
https://git-wip-us.apache.org/repos/asf?p=incubator-cordova-ios.git;a=commit;h=e1781b0302ff51cb65581f08b783a420f6371ede

I think in this case it would pass on the simulator but BAD_ACCESS
on-device.

I'm not seeing a failure in File related tests though. Tried going back &
forth a few times on both iPhone 3gs and iPad2.


On Wed, Sep 5, 2012 at 2:38 PM, Andrew Grieve <agrieve@chromium.org> wrote:

> Just tried this on my 3gs and got a BAD_ACCESS within FileTransfer upload
> on my first try. Looking into it...
>
>
> On Wed, Sep 5, 2012 at 12:20 PM, Becky Gibson <gibson.becky@gmail.com>wrote:
>
>> I am getting an inconsistent crash when I run the automated mobile-spec
>> file tests on the iOS simulator or my iPhone 4S.  Sometimes the tests run
>> fine but others I get an EXEC_BAD_ACCESS.  Can someone else please test?
>>  You may need to run the test multiple times (just go back out of a
>> successful file test and try again - at most it only takes me 3 tries to
>> crash).
>>
>> I tried setting breakpoints on execptions,  I also tried profiling with
>> zombies but neither provided any useful info. It seems related to the file
>> move tests - either with  *entry.move.fnp.file1 or *entry.move.dsp.srcDir
>> as the src.  And of course, if I step through the code for those move test
>> sin the debugger it doesn't crash.
>>
>> I'll try creating  a new project to see if that helps.
>>
>> -becky
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message