incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Reinstein (JIRA)" <>
Subject [jira] [Commented] (CB-1464) bin/create script is broken on tagged 2.1.0 release
Date Tue, 18 Sep 2012 21:41:07 GMT


Mike Reinstein commented on CB-1464:

Hey Joe,

Do you have a pointer to the commons-code issue? I *think I may be running into this myself.
When I run the create script, I get this error: An error occured. Deleting project...

I added stubs to the create script to track the line that seems to be failing. It's this one:
unzip &> /dev/null

Here is my output when I run the unzip manually:

$ unzip 

  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of or, and cannot find, period.

> bin/create script is broken on tagged 2.1.0 release
> ---------------------------------------------------
>                 Key: CB-1464
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>    Affects Versions: 2.1.0
>            Reporter: Olivier Louvignes
>            Priority: Minor
> script can't find :
> - framework/assets/www/cordova-2.1.0.js
> - framework/cordova-2.1.0.jar
> building the framework failed :
> cordova-android/framework$ ant jar
> Buildfile: /Users/olivier/Dropbox/Developer/cordova/cordova-android/framework/build.xml
> -check-env:
> /Volumes/android/android-sdk/tools/ant/build.xml:389: java.lang.NumberFormatException:
For input string: "21 rc3"
> Would love to understand how I can create a project with this new tagged 2.1 release.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message