incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Moe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-1555) Cordova 2.1.0 & ios - Can't type on input fields
Date Thu, 27 Sep 2012 21:07:09 GMT

    [ https://issues.apache.org/jira/browse/CB-1555?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13465091#comment-13465091
] 

Moe commented on CB-1555:
-------------------------

Yes, I am getting this issue on my mac os x 10.8.2 mountain lion which is currently the latest
version of mac os x, with xcode 4.5 which is the latest version of xcode... the problem occurs
on all of the iOS simulators and it also occurs on my actual iphone device as well. It occurs
on iOS 5 and iOS 6, simultor & actual device. I also have another mac running os x version
10.7.4 with xcode 4.2 and the problem occurs there as well. The app was working fine in cordova
version 2.0 and started happening once I upgraded to cordova 2.1.0 by following the upgrade
steps listed in the documentation here:

http://docs.phonegap.com/en/2.1.0/guide_upgrading_ios_index.md.html#Upgrading%20Cordova%20iOS

I also tried to create a test project using the cordova bin/create, you know the default cordova
project you get once you create a new cordova project, and I added a simple text input field
on that page as well to see if it does the same thing and sure enough the problem exists there
as well. So it is also happening when I try on a default cordova app, not just in my app.
                
> Cordova 2.1.0 & ios - Can't type on input fields
> ------------------------------------------------
>
>                 Key: CB-1555
>                 URL: https://issues.apache.org/jira/browse/CB-1555
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>    Affects Versions: Master, 2.1.0
>         Environment: Cordova 2.1.0 & ios & mac os x mountain lion with xcode
4.5
>            Reporter: Moe
>            Assignee: Andrew Grieve
>
> Hello,
> Today I upgraded one of my apps to the latest version of cordova which is currently v2.1.0
from version 2.0.0 and everything on my app works fine except now I can't type into input
boxes. I go to a simple form in my app and I can't type in any of the input fields. I tap
on the input field, it focuses, and then when I start to type using my physical keyboard or
even the soft-keyboard in the simulator and it won't show the characters I type in the box,
so no text gets inputted. Seems like some kind of glitch or bug that was introduced in cordova
2.1.0... I then tried to download the latest master of cordova off the apache incubator and
the same problem exists with that version too.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message