incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Maj (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-1551) Android build, debug, emulate scripts should check SDK version(s)
Date Thu, 27 Sep 2012 19:43:09 GMT

     [ https://issues.apache.org/jira/browse/CB-1551?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Filip Maj updated CB-1551:
--------------------------

    Component/s: Android
       Assignee: Joe Bowser
    
> Android build, debug, emulate scripts should check SDK version(s)
> -----------------------------------------------------------------
>
>                 Key: CB-1551
>                 URL: https://issues.apache.org/jira/browse/CB-1551
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: Android
>         Environment: Mac OS X, Windows, Linux
>            Reporter: Mike Reinstein
>            Assignee: Joe Bowser
>            Priority: Minor
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> Need to check that the user has the right SDKs installed before proceeding. 
> the minimum version for Android is 4.1. APKs are backwards compatible, so as long as
you have code to handle API levels, use reflection and other tricks, a 4.1 APK will work all
the way back to Android 2.1 (or even 1.6).
> As far as SDK compatibility, we need the latest released Android SDK, which is currently
r20. We don't support r21 at the moment, and we don't test with against previous SDK versions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message