incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Santana (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-1122) Compile errors when building for Archive
Date Thu, 20 Sep 2012 22:00:09 GMT

    [ https://issues.apache.org/jira/browse/CB-1122?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13459997#comment-13459997
] 

Carlos Santana commented on CB-1122:
------------------------------------

Shazron, hehe I'm not that smart I took the variable from the debug script.

By adding this variable CONFIGURATION_BUILD_DIR actually I'm fixing two problems.
Problem #1: Compile Error
Since Header Search Path already contains the build $(BUILT_PRODUCTS_DIR) and this match $(CONFIGURATION_BUILD_DIR)
then the compiler will know where to find the include files to compile

Problem #2: Building a good IPA containing the cordovalib linked with compiled library
I tried fixing the header search path to make the compile work from command line this produced
an ipa that was not usable, the final output didnt' contain the cordovalib compiled.

The key thing is that the cordovalib output needs to be found by archive process to put everything
inside the ipa

This is why I took the shortcut of just adding the  $(CONFIGURATION_BUILD_DIR) to fix both
problems.

I hope this helps clarify.

I took me a while to figured out when I upgraded from cordova 1.6.1 to 2.0.0 and suddenly
I was not getting a good IPA to be install on phone for ad-hoc/enterprise distribution over
webpage.

--Carlos
                
> Compile errors when building for Archive
> ----------------------------------------
>
>                 Key: CB-1122
>                 URL: https://issues.apache.org/jira/browse/CB-1122
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>    Affects Versions: 2.0.0
>            Reporter: Shazron Abdullah
>            Assignee: Shazron Abdullah
>             Fix For: 2.1.0
>
>         Attachments: Archive-tmq.zip, header.png
>
>
> On Tue, Jul 24, 2012 at 4:45 PM, Michael McCabe <michaelmccabe5@gmail.com> wrote:
> > I'm having the same problem.  I tried installing Cordova-2.0.0.pkg before
> > running the create script and am still getting the errors of missing
> > CDVViewController.h (in AppDelegate.h and MainViewController.h) only when
> > archiving.  
> >
> > Has anyone gotten the build to work after installing the pkg?  I'm running
> > XCode 4.2, mac-os 10.6.8 and ios sdk 5.0, btw.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message