incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Grieve (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-675) Allow multiple versions of PhoneGap to be installed in Xcode
Date Mon, 13 Aug 2012 14:32:38 GMT

    [ https://issues.apache.org/jira/browse/CB-675?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13433173#comment-13433173
] 

Andrew Grieve commented on CB-675:
----------------------------------

(moving response from mailing-list to JIRA now that it's alive again)

Having to run make before, and having it modify xcode settings is a bit troublesome I think.
It would be really great if a generated project would work without having to modify xcode's
source locations. For example, on my last project we had a shared build machine that we could
ssh into and use xcodebuild to ensure our patches compiled cleanly. It would be pretty tricky
to ssh in, set the project source location, build, and clean up afterwards.

Since bin/create knows where its installation is (since the script is within the installation),
how about it sets up the CordovaLib subproject without any source variable indirection.

If users move their CordovaLib directory or want to switch to another version, they can update
the path to the sub-project using XCode. The icon right under "Relative to Group" on the right-hand
side lets you change the path of the sub-project entry.
                
> Allow multiple versions of PhoneGap to be installed in Xcode
> ------------------------------------------------------------
>
>                 Key: CB-675
>                 URL: https://issues.apache.org/jira/browse/CB-675
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>            Reporter: Andrew Trice
>            Assignee: Shazron Abdullah
>             Fix For: 2.1.0
>
>
> There is one thing that is driving me crazy with PhoneGap.  Currently in OSX, the Xcode
project always references the machine's PhoneGap library.  For a single project, this is fine.
 If you have multiple projects on your machine, and they use different versions of the PhoneGap
SDK, then there is no way to easily manage the correct version of the SDK.  Whether your project
is PhoneGap 1.5 or 1.7, it will reference the last installed SDK.   If you try and run a PhoneGap
1.5 app on a machine where you last installed the 1.7 RC, then the 1.5 app is likely to have
errors (compiler errors from changes in the SDK, as well as JS errors).   It would be great
to have either versioned SDK libraries so that you can have multiple PhoneGap versions installed
at the same time, or have a reference to the PhoneGap library in each project, so that installing
a new SDK doesn't break older projects.   

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message