incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Grieve (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-675) Allow multiple versions of PhoneGap to be installed in Xcode
Date Mon, 20 Aug 2012 17:45:38 GMT

    [ https://issues.apache.org/jira/browse/CB-675?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13438023#comment-13438023
] 

Andrew Grieve commented on CB-675:
----------------------------------

Ha! Not the best script outcome :P

I'm glad you agree about the approach though.

I updated the script on my branch to not suck.
I also added a copy of the script that uses plistlib. All it does is try to read it, but it
complains the file is invalid.

Using plutil looks like it removes all of the comments in the file. The thing I like about
the regex approach (when it doesn't suck), is that it will leave all of the comments intact.
and the diff between the before & after should be only a single line.

I'm hoping users will just update the subproject via the GUI, but the command-line support
would be required only for automated testing.

                
> Allow multiple versions of PhoneGap to be installed in Xcode
> ------------------------------------------------------------
>
>                 Key: CB-675
>                 URL: https://issues.apache.org/jira/browse/CB-675
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>            Reporter: Andrew Trice
>            Assignee: Shazron Abdullah
>             Fix For: 2.1.0
>
>         Attachments: project_template.diff.png
>
>
> There is one thing that is driving me crazy with PhoneGap.  Currently in OSX, the Xcode
project always references the machine's PhoneGap library.  For a single project, this is fine.
 If you have multiple projects on your machine, and they use different versions of the PhoneGap
SDK, then there is no way to easily manage the correct version of the SDK.  Whether your project
is PhoneGap 1.5 or 1.7, it will reference the last installed SDK.   If you try and run a PhoneGap
1.5 app on a machine where you last installed the 1.7 RC, then the 1.5 app is likely to have
errors (compiler errors from changes in the SDK, as well as JS errors).   It would be great
to have either versioned SDK libraries so that you can have multiple PhoneGap versions installed
at the same time, or have a reference to the PhoneGap library in each project, so that installing
a new SDK doesn't break older projects.   

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message