incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bowser (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (CB-569) Script tags embedded in body content referencing packaged .js file do not load on Android 4.x
Date Tue, 24 Jul 2012 18:55:35 GMT

     [ https://issues.apache.org/jira/browse/CB-569?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joe Bowser closed CB-569.
-------------------------

    Resolution: Won't Fix
      Assignee: Joe Bowser  (was: Filip Maj)

This is more like a "Can't Fix".  This is related to the resource bug in Android 3.x to 4.0.4
where it can't read from a Java Input Stream, which is how the browser accesses the files
bundled in a manifest.

Can you open a new bug for the 2.2 phone? That seems like a separate issue.
                
> Script tags embedded in body content referencing packaged .js file do not load on Android
4.x
> ---------------------------------------------------------------------------------------------
>
>                 Key: CB-569
>                 URL: https://issues.apache.org/jira/browse/CB-569
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>    Affects Versions: 1.6.1, 1.7.0
>         Environment: Can reproduce with Cordova 1.6.1 and 1.7.0 on the following devices:
>  - ASUS Transformer TF101 (Android 3.2)
>  - HTC Desire Z (Android 2.2.1)
>  - Samsung Galaxy Nexus (4.0.2)
>  - Emulator (4.0.3)
> Cannot reproduce on:
>  - Emulator running 2.3.3
>            Reporter: Eugene Grybinnyk
>            Assignee: Joe Bowser
>            Priority: Minor
>
> I've created a simple jqm app with 2 screens - when you click any on the first screen
(index.html) you will follow to the second screen (second_screen.html). Second screen is including
some js code in it's body as external file (with a simple alert inside).
> So an *Expected Result* - I click on link and see alert message
> When I deploy it on my local apache httpd server - it's working fine on desktop browsers,
and native mobile browsers on ASUS Transformer TF101 (ASUS) and HTC Desire Z (HTC).
> Then, I create a Phonegap (Cordova) project on Eclipse using PhonegapForAndroid plugin
(target api - 7, android 2.1), export signed apk and install in on ASUS and HTC.
> And *Actual Result* - apk installed on HTC - works like in a browser, but the same apk
installed on ASUS - doesn't work properly - I click on a link and don't see alert.
> * I tried to reassemble the apk specifying target api - 13 (android 3.2) but it had no
effect for ASUS device.
> * I tried to run the problematic apk-s on android virtual device (api 13, android 3.2)
and it works fine (both apk-s, with 7 and 13 target api-s).
> PS /
>  Links:
> HTML/CSS/JS bundle http://dl.dropbox.com/u/33175266/external_js_test_jqm.zip
> Eclipse project (target api - 7) http://dl.dropbox.com/u/33175266/external_js_test_jqm_api7.zip
> Eclipse project (target api - 13) http://dl.dropbox.com/u/33175266/external_js_test_jqm_api13.zip
> Signed apk (target api - 7) http://dl.dropbox.com/u/33175266/external_js_test_jqm_api7_signed.apk
> Signed apk (target api - 13) http://dl.dropbox.com/u/33175266/external_js_test_jqm_api13_signed.apk
> PSS /
>  There are two links in the project, first is handled with jqm implicitly and second
is calling jqm function $.mobile.changePage via handler, attached with jQuery.live on vclick
event. Both of them are working well on browsers and HTC and are not working on ASUS. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message